BMW F800 Forum banner
21 - 33 of 33 Posts

· Administrator
Joined
·
11,521 Posts
Well, if you owned an electric motorcycle that sat out in the rain for any length of time you would be seeing all sorts of strange things. :rolleyes:
 

· Registered
Joined
·
236 Posts
Might be the idle air control (idle controller) valve

it’s on the bottom of the air box
to clean it; Spray the unit with choke/carburetor cleaner and use a clean rag to remove all carbon buildup. Work the spindle back and forth
 

· Registered
Joined
·
24 Posts
Discussion Starter · #25 ·
Update: I went to the BMW dealer to return some bike parts and asked their service head about this issue.

He said it's the fuel pump before I was even able to finish explaining the entire situation. Says hes seen it a million times. I'll be installing the pump tomorrow and see what happens.
 

· Registered
Joined
·
543 Posts
Update: I went to the BMW dealer to return some bike parts and asked their service head about this issue.

He said it's the fuel pump before I was even able to finish explaining the entire situation. Says hes seen it a million times. I'll be installing the pump tomorrow and see what happens.
BMW only sells the fuel pump as an entire assembly but the pump alone is readily available in the aftermarket.
 

· Registered
Joined
·
2,178 Posts
I hate replacing random parts until the bike is fixed.
 

· Registered
Joined
·
968 Posts
I would be shockingly surprised if coils were your issue. Maybe fuel pump regulator?

For that matter, any bmw dealership in the US that claims to acknowledge any issue with an F800 is extremely rare. Few of them have ever even seen an F800ST.

Unfortunately I realize that my comments don't help you much.

Sent from my SM-G991U using Tapatalk
 

· Registered
Joined
·
24 Posts
Discussion Starter · #30 ·
The new fuel pump has a constant electric tone while the bike runs, the fuel pump doesn't need to be programmed right? I remember the original fuelpump only beeped for about 4 seconds.

Also the bike dies at basically engine temp of 95 degrees celsius everytime. If I let it cool down for 2 minutes itl turn on. Is there some kind of engine temp cutoff sensor or something? maybe thats broken.
 
21 - 33 of 33 Posts
Top